Monday, 4 January 2016

Error while Configuring App Urls

The Subscription Settings service and corresponding application and proxy needs to be running in order to make changes to these settings. 




Solution:

Central Administration -> Application Management -> Service Applications -> Services on the Server


Click Start button of  

App Management Service and Microsoft SharePoint Foundation Subscription Settings Service 


























If you are still facing same issue then do an IISReset which will fix the issue.



Alternative We can RunPowerShell Scirpt to fix the issue if You haven't configured Service applications for AppManagement and Subscirption Service Settings 



cls
asnp "*sh*"


Get-SPServiceInstance |?{$_.TypeName -like  "App Management Service"| Start-SPServiceInstance

Get-SPServiceInstance | ? {$_.TypeName -like "Microsoft SharePoint Foundation Subscription Settings Service"| Start-SPServiceInstance

#Provide the service account as per your configuration 

$account=Get-SPManagedAccount -Identity CORP\Svc.AppsAccount

#configure Subscription Service Application for Sharepoint

$appPoolSubsvc=New-SPServiceApplicationPool -Name "SubscriptionServericeAppPool" -Account $account
$appSubSvc=New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPoolSubsvc -Name "Subscription Service Application" -DatabaseName SubscriptonServiceDB
$proxySubSvc=New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $appSubSvc
Write-Host "Subscirption Service Application Created"


$appPoolAppSvc= New-SPServiceApplicationPool -Name "AppManagementServiceAppPook" -Account $account
$appsMgmtSvc= New-SPAppManagementServiceApplication -ApplicationPool $appPoolAppSvc -Name "Apps Management Service" -DatabaseName "AppsDb"
$proxyAppSvc=New-SPAppManagementServiceApplicationProxy -ServiceApplication $appsMgmtSvc

Write-Host "Apps Management Service Application Created"